Parallels Screws Up Version 4

Recently Parallels released version 4 of their virtual machine software which I have been using for many years now and have been recommending to everyone I can. I use the MAC version so I can run Vista (even tried Windows 7) and until this version it worked like a charm! But after upgrading to version 4, spending 12 days emailing tech support back and forth the performance is much worse than version 3! Here are just some of the issues I was having besides the terrible performance:

  1. Takes 4 minutes to boot the image.
  2. While running,
    programs run slow in the virtual image AND on my MacBook Pro! Clicking
    on programs etc. sometimes does nothing for up to 30 seconds.
  3. Network (internet) runs very slow in the virtual image AND on my MacBook Pro!
  4. Takes 4 minutes to shut down image.

Tech support was very helpful and tried every trick in the book to get my vm to run faster, which it did, but still was too slow. Why should it take 12 days of emails to get it to work better, shouldn’t it just work like that when I start it?

So my recommendation is do not use this version until these issues are worked out and I will not be recommending it anymore. Sorry Parallels.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: